Autodesk 3D Studio Max/3Ds Max-ში მუშაობის პრინციპები

ვიკიწიგნებიდან
გადასვლა: ნავიგაცია, ძიება

ობიექტების შექმნა[რედაქტირება]

მაქსში ობიექტების შექმნა ხორციელდება ბრძანებების პანელიდან, Create (შექმნა) ჩანართიდან.

იმისათვის რომ შექმნათ ობიექტი გააკეთეთ შემდეგი:

  • ბრძანებების პანელზე გადადით ჩანართზე Create (შექმნა);
  • აირჩიეთ კატეგორია სადაც იმყოფება თქვენთვის სასურველი ობიექტი, მაგალითისათვის კატეგორია Geometry (გეომეტრია).
  • გახსნილი სიიდან აირჩიეთ ჯგუფი რომელში იმყოფება თქვენთვის სასურველი ობიექტი. მაგალითისათვის ჯგუფი Standard Primitives (უბრალო პრიმიტივები).
  • დააჭირეთ ობიექტის სახელის ღილაკს.
  • პროექტირების ფანჯარაში ნებისმიერ ადგილას დააჭირეთ თაგუნას მარცხენა ღილაკს და თითის აუშვებლად გასწიეთ იგი სასურველი მიმართულებით სანამ იგი არ მიიღებს სასურველ ზომას.


რჩევა!
ობიექტების შექმნა ასევე შესაძლებელია Keyboard Entry (კლავიატურიდან შეყვანა)-ში ობიექტების პარამეტრების შეყვანის მეშვეობით (სურ. 12). ამისათვის შესაქმნელი ობიექტის ღილაკზე დაჭერისას გამოჩენილ სიაში შეიყვანეთ ობიექტის პარამეტრები და დააჭირეთ ღილაკს Create (შექმნა).

სურ 12. Keyboard Entry (კლავიატურიდან შეყვანა).gif

პროექტირების ფანჯრებში ობიექტი შესაძლებელია იყოს წარმოდგენილი სხვადასხვანაირად: გლუვად - დათვარიელების რეჟიმში Smooth + Highlights (სიგლუვე + შუქური ეფექტები), უჯრედული გარსების რეჟიმში - Wireframe (ჩარჩო), რედაქტირების საზღვრების რეჟიმში Bounding Box (მაკავშირებელი ოთხკუთხედი) და სხვა.

პროექტირების ფანჯრებში ობიექტების შემცირებულად გამოსახვა საჭიროა იმისათვის, რომ მომხმარებლისთვის ადვილი იყოს რთულ სცენებთან და დიდი რაოდენობის პოლიგონებთან მუშაობა.


შემიშვნა!
მაქსთან მუშაობასთან გამოყენებად ტერმინოლოგიებში ხშირად შევხვდებით ტერმინს Gizmo (გაბარიტული კონტეინერი გიზმო). ის უზრუნველყოფს ობიექტის გეომეტრიულ ზომებს და აქვს მომცრო თაროს ფორმა. სფეროსა და ცილინდრის ფორმის Gizmo (გაბარიტული კონტეინერი გიზმო) გამოიყენება ასევე ობიექტის ატმოსფერული ეფექტების შესაქმნელად - განსაზღვრავს მათი გავრცელების საზღვრებს, მაგალითად, ბურთის გარშემო წვას.

იმისათვის რომ შეცვალოთ ობიექტის გამოსახულება პროექტირების ფანჯრებში, თაგუნას მარჯვენა ღილაკით იმოქმედეთ პროექტირების ფანჯრის დასახელებაზე და ჩამოშლილ კონტექსტურ მენიუში აირჩიეთ სასურველი რეჟიმი(სურ. 13).

სურ 13.ობიექტის გამოსახულების რეჟიმის არჩევა.gif

ობიექტების მონიშვნა[რედაქტირება]

3ds max-ში არსებობს ობიექტების მონიშვნის რამოდენიმე საშუალება. ყველაზე უბრალო - ობიექტზე დაწკაპუნება Select Object (ობიექტის მონიშვნა)-ის საშუალებით, რომელიც განთავსებულია მთავარი ინსტრუმენტების პანელზე. თუკი თქვენ იმყოფებით ობიექტის გამოსახვის Wireframe (ჩარჩო) რეჟიმში, ობიექტის ფერი გახდება თეთრი(სურ. 14).

სურ 14.ობიექტის მონიშვნა რეჟიმში Wireframe (ჩარჩო).gif

რჩევა!
როდესაც ობიექტი მონიშნულია Wireframe (ჩარჩო) რეჟიმში, კარგი იქნება თუ ობიექტი არ იქნება თეთრი, რადგან გარჩევა შეუძლებელი იქნება მონიშნულ და მოუნიშნავ ობიექტებს შორის.

რეჟიმ Smooth+Higlights-ში მონიშვნისას,მინიშნული ობიექტის გარშემო გაჩნდება თეთრი კვადრატული ხაზები(სურ. 15).

სურ 15.მონიშვნა რეჟიმ Smooth+Higlights-ში.gif

ობიექტების ერთდროულად მონიშვნის სხვა საშუალებაა - რეგიონების მონიშვნა. ამ რეჟიმში არსებობს ობიექტების მონიშვნის რამოდენიმე საშუალება. გაჩუმების პრინციპით გამოიყენება Rectangular Selection Region (ოთხკუთხედოვანი მონიშვნა). მონიშვნის ამ რეჟიმით მონიშვნისას აუცილებელია თაგუნაზე თითის აუღბლად შემოვხაზოთ მოსანიშნი ობიექტები(სურ. 16).

სურ 16.ობიექტების მონიშვნა რეჟიმში Rectangular Selection Region (ოთხკუთხედოვანი მონიშვნა).gif

შესაძლებელია ობიექტების მონიშვნა სხვადასხვა ფიგურების მეშვეობით. ობიექტების რეჟიმების გადასართველად საჭიროა ვისარგებლოთ მთავარი ინსტრუმენტების პანელზე არსებული ღილაკით. არსებობს ობიექტების მონიშვნის ხუთი ვარიანტი(სურ. 17).

სურ 17.მონიშვნის ღილაკები.gif

მონიშვნის რეჟიმები :

  • Rectangular Selection Region (ოთხკუთხედოვანი მონიშვნა);
  • Circular Selection Region (მრგვლოვანი მონიშვნა) (სურ. 18);
  • Fence Selection Region (რეგიონის შემოღობვით მონიშვნა) (სურ. 19);
  • Lasso Selection Region (ლასოთი მონიშვნა) (სურ. 20);
  • Paint Selection Region (ფუნჯით მონიშვნა) (სურ. 21);

ჩამოთვლილი ღილაკებით მონიშვნამდე შესაძლებელია გამოვიყენოთ ღილაკი Window/Crossing (ფანჯარა/გადახაზვა).

როდესაც რეგიონის მონიშვნამდე ვრთავთ რეჟიმს Crossing (გადახაზვა), მაშინ მონიშნულები იქნებიან ის ობიექტები რომლებიც მთლიანად, ან რაღაც ნაწილით მოხვდებიან ამ რეგიონში. თუკი ჩავრთავთ რჟიმს Window (ფანჯარა), მოინიშნებიან ის ობიექტები რომლებიც მთლიანად მოხვდებიან რეგიონში.

იმისათვის რომ მოვნიშნოთ რომელიმე ობიექტის სცენა, ამისათვის ასევე შესაძლებელია ვისარგებლოთ მენიუთი Edit > Select By > Name (რედაქტირება>მონიშვნა >სახელი). ამის შემდეგ ეკრანზე გამოვა ფანჯარა Select Objects (ობიექტების მონიშვნა) ობიექტების სცენის სიით(სურ. 22).

სურ 22.ფანაჯარა Select Objects (ობიექტების მონიშვნა).gif

ფანჯრის List Types (სიის ტიპები) ნაწილში შესაძლებელია ავირჩიოთ გამოსახული ობიექტების ტიპები. Sort (დახარისხება) ნაწილში განვსაზღვროთ ობიექტის გამოსახულების განლაგება - Alphabetical (ანბანის მიხედვით), By Type (ტიპის მიხედვით), By Color (ფერის მიხედვით), By Size (ზომის მიხედვით). ობიექტების მონიშვნის ფანჯრის გამოყენება მოსახერხებელია მაშინ როდესაც სცენა შეიცავს ბევრ ობიექტს.

რჩევა !
Select Objects (ობიექტების მონიშვნა) ფანჯრის გამოსაძახებლად შეგვიძლია ვიმოქმედოთ ღილაკზე H,ან ღილაკით Select by Name (სახელით არჩევა) მთავარი ინსტრუმენტების პანელზე.

პატარა ობიექტების შემცველ დიდი რაოდენობის ობიექტების სცენასთან მუშაობისას, ხშირია არასაჭირო ობიექტის მონიშვნა, ან საჭირო ობიექტის ამოღება. იმისათვის რომ ეს არ მოხდეს ვისარგებლოთ Selection Lock Toggle (ბლოკირებული მონიშვნა) ბრძანებით. მონიშნეთ ობიექტი და დააჭირეთ ბოქლომის გამოსახულების ღილაკს, რომელიც განთავსებულია ანიმაციის ზოლის ქვემოთ, ან დააჭირეთ ღილაკს Space.

პრიმიტიული ოპერაციები ობიექტებზე[რედაქტირება]

ობიექტების შექმნისას მთავარი ქმედებებია - გადაადგილება , მასშტაბირება , ტრიალი , გათანასწორება და კლონირება.

გამოყოფილი ობიექტის ცენტრში ჩნდება სამი კოორდინატთა ღერძი - X, Y და Z, რომლებიც განსაზღვრავენ ობიექტზე მიბმულ კოორდინატთა სისტემას. ეს საკოორდინატო ღერძები აერთიანებენ ე.წ. ობიექტის ლოკალური სისტემის კოორდინატებს. წერტილს, საიდანაც გამოდიან კოორდინატების ლოკალური სისტემის ღერძები, ეწოდება მყარი(Pivot Point).

ყურადღება!
მყარ წერტილს ყოველთვის სვამენ ობიექტის ცენტრში, თუმცა ისინი შეისაძლებელია არ დამეთხვეს. მაგალითად, გაჩუმების პრინციპით სფეროზე მყარი წერტილი ემთხვევა ცენტრს, მაგრამ თუ სფეროს შევცვლით Hemisphere (ნახევარსფერო)-თი, მაშინ მყარი წერტილი განთავსებულ იქნება ობიექტის ცენტრის ქვემოთ.

იმისათვის რომ ობიექტებზე შევასრულოთ პრიმიტიული ოპერაციეი, ამისათვის აუცილებელია გამოვიძახოთ კონტექსტური მენიუ, ობიექტზე თაგუნას მარჯვენა ღილაკით დაჭერისას(სურ. 23).

სურ 23.კონტექსტური მენიუ.gif


გადაადგილება[რედაქტირება]

კონტექსტურ მენიუში აირჩიეთ ბრძანება Move (გადაადგილება), მიიტანეთ კურსორი იმ კოორდინატთა ღერძთან რა მიმართულებითაც გსურთ ობიექტის გადაადგილება(სურ. 24). შესაძლებელია ობიექტების გადაადგილება X, Y, Z და XY, YZ, XZ მიმართულებებით.

სურ 24.ობიექტის გადადგილება YZ მიმართულებით.gif

ობიექტის გადადგილების კოორდინატების მითითება შესაძლებელია ასევე ფანჯარაში Move Transform Type-In (გადადგილების მნიშვნელობის შეყვანა)(სურ. 25), რომელიც გამოდის F12 ღილაკზე მოქმედებით, ან კონტექსტურ მენიუში Move (გადაადგილება)-სთან მყოფ ოთხუკთხედზე მოქმედებით.

სურ 25.ფანჯარა Move Transform Type-In (გადადგილების მნიშვნელობის შეყვანა).gif

რჩევა!
გამოყოფილი ობიექტის გადასაადგილებლად ასევე შესაძლებელია გამოვიყენოთ ღილაკი W.


ტრიალი[რედაქტირება]

კონტექსტურ მენიუში ბრძანება Rotate (ტრიალი)-ს არჩევისას ღერძების მაგივრად გამოჩნდება ტრიალის შესაძლებლობების სქემატური გამოსახულება(სურ. 26). თუკი კურსორს მივიტანთ რომელიმე მიმართულებასთან, იგი შეიცვლის ფერს და გახდება ყვითელი.

სურ 26.ობიექტის შემოტრიალება.gif

შემოტრიალების პროცესის დროს პროექტირების ფანჯარაში გამოჩნდება ციფრები, რომლების განსაზღვრავენ ყოველი ღერძის შემოტრიალების კუთხეს.


რჩევა!
გამოყოფილი ობიექტის ტრიალისათვის ასევე შესაძლებელია ღილაკ E-ს გამოყენება.


მასშტაბირება[რედაქტირება]

კონტექსტურ მენიუში აირჩიეთ ბრძანება Scale (მასშტაბირება), მიიტანეთ კურსორი ობიექტის ნებისმიერ საკოორდინატო ღერძთან, ამის შემდეგ ობიექტი გაიზრდება, ან დაპატარავდება იმ მიმართულებით რა მიმართულების კოორდინატთა ღირძის ფერიც არის ყვითელი(სურ. 27). მასშტაბირება შესაძლებელია X, Y და Z, ან XY, YZ, XZ მიმართულებებით. ასევე შესაძლებელია ობიექტის ერთდროულად ყველა მიმართულებით მასშტაბირება.

სურ 27.ობიექტის მასშტაბირება.gif

მასშტაბირებისას ობიექტი არ იცვლის მის გეომეტრიულ ზომებს, მიუხედავად იმისა რომ ეკრანზე იცვლება მისი პროპორციები. ამიტომ მასშტაბირების გამოყენება რეკომედრირებულია მხოლოდ აუცილებლობის შემთხვევაში, რადგან ამ ოპერაციის შესრულების შემდეგ თქვენ ვერ დაინახავთ რეალურ ზომებს და შესაძლებელია დაიბნეთ.

რჩევა!
მასშტაბირების შესასრულებლად ასევე შეგვიძლია ვისარგებლოთ R ღილაკით.


ობიექტების გათანასწორება[რედაქტირება]

მუშაობის პროცესში ხშირად გვიწევს გადავაადგილოთ ობიექტები, მათი მგომარეობის ერთმანეთთან გათანასწორებისათვის. მაგალითად, რთული მოდელების შექმნისას, აუცილებელია, დეტალები რომლებიც იქმნებიან ცალკე, გათანასწორდნენ სხვა ელემენტებთან. იმისათვის რომ ორი ობიექტი გავათანასწოროთ, აუცილებელია გამოვყოთ პირველი ბრძანებით Tools > Align (ინსტრუმენტები/გათანასწორება) და დავაჭიროთ მეორე ობიექტს. ეკრანზე გამოვა ფანჯარა(სურ. 28), რომელშიც უნდა მივუთითოთ გათანასწორების პრინციპი, მაგალითად, შესაძლებელია დავსვათ საკოორდინატო ღერძები ან წერტილები ობიექტზე, რომელთა წინაც მოხდება ობიექტების გათანასწორება.

სურ 28.ფანჯარა Align Selection (გამოყოფილი ობიექტების გათანასწორება).gif

დავუშვათ რომ გასაერთიანებელია ორი ობიექტი, ერთ-ერთი პატარაა მეორეზე, ხოლო გაერთიანების პრინციპით პატარა უნდა მოხვდეს დიდის ცენტრში, ამისათვის ფანჯარა Align Selection (გამოყოფილი ობიექტების გათანასწორება)-ში მივუთითოთ შემდეგი :

  • მოვნიშნოთ X Position (Х-პოზიცია), Y Position (Y-პოზიცია) и Z Position (Z-პოზიცია);
  • გადამრთველი Current Object (ობიექტი, რომელიც თანასწორდება) - Center (ცენტრი) მდგომარეობაში;
  • გადამრთველი Target Object (ობიექტი, რომელთანაც თანასწორდება) - Center (ცენტრი) მდგომარეობაში.

დააჭირეთ ღილაკს OK, ან Apply.

რჩევა!
ობიექტების გათანასწორებისათვის ასევე შესაძლებელია გამოვიყენოთ ღილაკების კომბინაცია Alt+A.

ობიექტების კლონირება[რედაქტირება]

იმსათვის რომ პროექტირების ფანჯარაში შევქმნათ გამოყოფილი ობიექტის კლონი, საჭიროა შევასრულოთ ბრძანება Edit > Clone (რედაქტირება> კლონირება). ეკრანზე გამოვა ფანჯარა Clone Objects (ობიექტების კლონირება)(სურ. 29). ამ ფანჯარაში შესაძლებელია ავირჩიოთ კლონირების სასურველი ვარიანტი.

სურ 29. ფანჯარა Clone Objects (ობიექტების კლონირება).gif

  • Copy (ობიექტის დამოუკიდებელი კლონი) - შექმნილი ობიექტი არ იქნება დაკავშირებული ორიგინალთან.
  • Instance (ობიექტის დამოკიდებული კლონი) - კლონი დაკავრშირებული იქნება ორიგანალ ობიექტზე. თუ რომელიმეს პარამეტრებს შევცვლით, შეიცვლება მეორე ობიექტის პარამეტრებიც.
  • Reference (მითითება) - კლონი დაკავრშირებული იქნება ორიგანალ ობიექტზე. თუ შევცვლით ორიგინალი ობიექტის პარამეტრებს, შეიცვლება კლონისაც, თუმცა, თუ შევცვლით კლონირებული ობიექტის პარამეტრებს, ორიგინალი ობიექტის პარამეტრები არ შეიცვლება.

რჩევა!
Clone Objects (ობიექტების კლონირება) ფანჯრის გამოსაძახებლად ასევე შესაძლებელია გამოვიყენოთ ღილაკთა კომბინაცია Ctrl + V.

არსებობს ობიექტის კლონირების კიდევ ერთი საშუალება ღილაკ Shift-ის მეშვეობით. გამოყავით ობიექტი, დააჭირეთ ღილაკს Shift, შემდეგ თაგუნას მარცხენა ღილაკით იმოქმედეთ ობიექტზე გამოსახულ რომელიმე საკოორდინატო ღერძზე.


კლონირება და გათანასწორება[რედაქტირება]

მაქსში არის ბრძანება ობიექტების ერთდროულად კლონირებისა და გათანასწორებისა. ამის დახმარებით, თაგუნას ერთი დაჭერით შესაძლებელია შევქმნათ გამოყოფილი ობიექტის რამოდენიმე კლონი და ამავდროულად განვსაზღვროთ მათი თანასწორობა. ეს ბრძანება შესაძლებელია გამოგვადგეს, მაგალითად, გზებზე განათებების შექმნისას. ვთქვათ გვაქვს ერთი ასეთი განათება, რომელსაც ესაჭიროება მრავალჯერ კლონირება. ამავდროულად ყველა შექმნილი ობიექტი უნდა გავათანასწოროთ ბოძის ზედა მხარესთან.

იმისათვის რომ ერთდროულად შევქმნათ ობიექტის კლონები და გავათანაასწოროთ ისინი, შევასრულოთ შემდეგ ბრძანება Tools > Clone and Align (ინსტრუმენტები > კლონირება და გათანასწორება)(სურ. 30).

სურ 30. ბრძანება Tools , Clone and Align (ინსტრუმენტები, კლონირება და გათანასწორება).gif

ამის შემდეგ გამოვა დიალოგური ფანჯარა Clone and Align (კლონირება და გათანასწორება)(სურ. 31).აუცილებელია გამოვყოთ ობიექტები Pick (არჩევა) ღილაკის მეშვეობით, რომლებთანაც გათანასწორდებიან შექმნილი კლონები.

სურ 31. დიალოგური ფანჯარა Clone and Align (კლონირება და გათანასწორება).gif

ობიექტების დაჯგუფება[რედაქტირება]

რთული გეომეტრიის მქონე სამგანზომილებიან ობიექტებს შესაძლებელია გააჩნდეთ დიდი რაოდენობის პატარა ელემენტები. მაგალითად, ავტომობილი შედგება კარებებისაგან, ფარებისაგან, საბურავებისაგან, ფანჯრებისაგან და ა.შ. იმისათვის რომ ასეთ ელემენტებთან მუშაობა მოსახერხებელი იყოს, მაქსში განხილულია ოპერაცია ობიექტების დაჯგუფება. ამ მეთოდით, დიდი რაოდენობის ობიექტების მაგივრად ჩვენ ვიღებთ მხოლოდ ერთს. დაჯგუფების შემდეგ ობიექტთან მუშაობა შესაძლებელია ისევე როგორც ნებისმიერ სამგანზომილებიან ობიექტთან - ტრიალი, გადადგილება, მასშტაბირება და ა.შ. ობიექტების დასაჯგუფებლად შევასრულოთ შემდეგი ოპერაცია:

  • 1.გამოვყოთ დასაჯგუფებელი ობიექტები;
  • 2.შევასრულოთ ბრძანება Group > Group (დაჯგუფება > დაჯგუფება)(სურ. 32);

სურ 32. ბრძანება Group, Group (დაჯგუფება, დაჯგუფება).gif

  • 3.დიალოგურ ფანჯარაში Group (დაჯგუფება)(სურ. 33),ველში Group name (ჯგუფის დასახელება) მიუთითეთ ჯგუფის სახელი.

სურ 33. .დიალოგური ფანჯარა Group (დაჯგუფება).gif